TYPO3-EXT-SA-2020-008: Cross-Site Scripting in "SVG Sanitizer" (svg_sanitizer)

  • Release Date: May 12, 2020
  • Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.
  • Component: SVG Sanitizer (ext:svg_sanitizer)
  • Vulnerability Type: Cross-Site Scripting
  • Affected Versions: 1.0.2 and below
  • Severity: Medium
  • Suggested CVSS v3.1: AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C
  • References: CVE-2020-11070, CWE-79

Problem Description

Slightly invalid or incomplete SVG markup is not correctly processed and thus not sanitized at all. Albeit the markup is not valid it is still evaluated in browsers can lead to Cross-Site Scripting.

Solution

An updated version 1.0.3 is available from the TYPO3 extension manager and at

https://extensions.typo3.org/extension/download/svg_sanitizer/1.0.3/zip/

Users of the extension are advised to update the extension as soon as possible.

Credits

Thanks to Matteo Bonaker who reported this issue and to TYPO3 merger Frank Nägler who fixed the issue.

General Advice

Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.

Zurück